Crawl.exe or installer.exe not running

Anyone with any advice on this issue?

When I download the Zip file and run “crawl.exe”, it simply won’t open. No errors or anything. Just get a spinning circle for a second or two, then nothing.

It has always worked in the past for me, and it works fine on other computers, just not the one I’m on. The weird thing is, I also tried downloading the Windows Installer, and that “…installer.exe” won’t run either.

Yes, I checked that other “exe” files open fine my system, and checked the registry settings, etc with anything associated with running exe files. Have no other issues opening any other exe file.

  1. I’m running Windows 11, all the latest updates
  2. No viruses or infections found on the system (I run a very clean system)
  3. Tried to run it as Administrator for both the Zip and Installer files (by right-click, and by Properties)
  4. Tried Compatibility settings in the Properties of each file running as Windows 7 & 8.
  5. Opened Task Manager to see if any program opens when I double-click on the crawl.exe file, and I don’t even see anything open

Anyone have any clues?