[SOLVED] Color scheme: Likely a foreground issue

I am playing on ubuntu linux and I intalled the 0.32 version and my color scheme is very bright:

As an example I would like something more “calm” like the below (I got told I can only put one media in each post, so will try to add the picture to a comment if possible).

So it is all still black, and there are colors, but it is not so bright.

I did try changing these values without the wanted result:

# background_colour = black
# foreground_colour = blue
# allow_extended_colours = false
# best_effort_brighten_foreground = false
# use_terminal_default_colours = false

Is there some resource with “color schemes” so I can copy paste some examples?

Or maybe someone could help me at least make the scheme less bright?

Here is the example of what I like:


I change my terminal colors as normal. (Assuming you’re using GNOME terminal here, you can check out https://gogh-co.github.io/Gogh/ to pick a palette you like and install it with ease)

Are you saying that this isn’t your normal terminal colors?

Yeah, it does not seem to be. Here is a screenshot from terminal:

It does not have the same bright foreground.

As shown then I tried to use use_terminal_default_colours but that did not do a difference.

1 Thank

Weird, it seems to work for me. Maybe it’s an rc issue? Try running crawl with the option set at command line and see if that works?

crawl -extra-opt-last use_terminal_default_colours=true (false is the default, setting it to true here should make it use your default background color)

You can do ctrl+p in the main menu to see where it’s loading the rc from.

That works very well!

Went back to the .rc and it were because I had not set the variable to true :frowning:

use_terminal_default_colours = false

Changed that and it works very well without the command line argument.

Thx for the help!

1 Thank