Trouble getting alt text to work... but only with one image

I'm gonna share my dcss memes here. Feel free to post your own

![EVOKE FEET. you can walk away!!! xom faded altar, sleepin unique, electric brand, ice cave door vault, orc priest, too fancy trove, attacks of oppurtunity if you're quick, anything that doesn't open doors. If it sucks... Hit da bricks! Real winners quit!|500x500, 75%](upload://dzWrK3xvQe4UGffa2Y65ADr4I9T.jpeg)
If it sucks... hit da bricks!!! <>

![Superhero comic book panels. A man in a coat walks away. He turns as a voice off-panel says, "so sad that Steve Jobs died of ligni." "Who's steve jobs?", the man replies. The off-panel voice, a super powered man, points his arm to the man in the coat and says, "A potion of lignification." In a flash of brilliant radiation, the man in the coat's body is replaced with DCSS tree-form art.|479x500, 75%](upload://kv3A6SaZz77e7ibDqHBHj3l1asx.jpeg)

![Steal their look meme template. Title Steal his look! There is only one item, a tile art of the DCSS unique Norris, a shirtless surfer riding a wave. There are instructions for changing the player tile to the Norris tile, listed below. 0 dollars.|496x261, 75%](upload://rr0HGt8vEJLE6w1zMecJoFy4bwK.png)

The last image doesn’t have alt text for some reason. Any idea why? I’ve tried removing it from it’s spoiler container and removing various special characters from the description. It’s much shorter than the one before it. The other 2 images display alt-text appropriately.

I’m still not 100% sure what’s going on here, but I think it’s this: for some reason, the “lightbox” feature only happens to images that are over a certain size (by default, 500px). So two of the images you uploaded meet this, but the third one doesn’t. The alt text is set (you can see it in the source, and I assume it would genuinely be readable for accessibility purposes), but it doesn’t automatically get the enhanced javascript stuff that the lightbox thing brings.

I don’t know enough about lightbox to know why it would be set up this way, maybe it’s simply that an image below a certain size doesn’t gain much by getting a modal popout. (and it’s a brand new feature for discourse, so searches aren’t bringing up too much). Also, I noticed it does appear work in preview, not sure of that either, maybe that’s a bug.

Reference: Some images don't lightbox? - ux - Discourse Meta

1 Thank

Good to know! Accessibility was the main drive so as long as that works I don’t mind that it doesn’t have hovertext lol.


1 Thank